Mustang Evolution Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
I dunno WTF happened with my car 2night but it was the weirdest thing Iv ever experienced driving

I was coming off a traffic circle and I didnt even stomp on it and just accelled normally and suddenly the car started rolling side to side and the rear end felt like it was going left while the car wanted to go right.....confusing i know. Then I checked the lugs, and suspension and everything seemed fine.....I ran the car up to 120 and it felt fine....

The car is lowered with FRPP P springs and is on MT ET Drag Radial pros and skinnies. I dunno if it was cause the tires were cold or what...anyone have any ideas??
 

·
It's not me, it's you.
Joined
·
6,752 Posts
Something might be wrong with the car so you take it to 120 to be sure? Do you have a mullet? Lol, I'm just bustin your balls. Is it a possibility that one of your springs were not seated properly? Or maybe there was something on the road, oil or grease?
 

·
Registered
Joined
·
185 Posts
Discussion Starter #3
Something might be wrong with the car so you take it to 120 to be sure? Do you have a mullet? Lol, I'm just bustin your balls. Is it a possibility that one of your springs were not seated properly? Or maybe there was something on the road, oil or grease?
LOL after doing it i was like hmmmmmmmm that was stupid haha. I had driven about 20 miles feeling for something and didnt feel anything. The springs have been on the car for at least 3k now and raced on and never felt anything like that. I dunno if one coulda turned or something. I mean maybe it coulda turned from weight transfer going around the circle??? I was thinkin oil or grease but i went back to the same circle, took it around, and it didnt do it the 2nd time....im stumped:confused:
 

·
Registered
Joined
·
92 Posts
I'm guessing had to do with the tires being cold or the setup. I've bolted up a buddy's ET streets before and the car felt real loose.
 

·
Registered
Joined
·
185 Posts
Discussion Starter #7
I'm guessing had to do with the tires being cold or the setup. I've bolted up a buddy's ET streets before and the car felt real loose.
Thats what i thought to, i pulled over and felt the tread and it was really really cold. Iv driven on em for about 1000 miles now and didnt feel that before.
 

·
Registered
Joined
·
1,171 Posts
SilverBullet12 said:
nope didnt feel like wheel hop. It legit felt like there was one person on each side of the rear of my car pushing it side to side haha.

I dont have a panhead bar so maybe the rear shifted???
No panhard bar? Are you running a watts link or something?

Sounds to me like you DRs were either rock solid because of cold temp or you hit water/oil.


Drifting without anticipating it must have been interesting.

Did you need a change of shorts?
 

·
Registered
Joined
·
185 Posts
Discussion Starter #9 (Edited)
No panhard bar? Are you running a watts link or something?

Sounds to me like you DRs were either rock solid because of cold temp or you hit water/oil.


Drifting without anticipating it must have been interesting.

Did you need a change of shorts?
...who says i was wearing shorts....LOL jk

i was told anything 1" and less in drop a panhard bar wasnt needed

yah i def did. Iv come off that circle pinned before and it stuck, def wasnt anticipating that at all.....
 

·
It's not me, it's you.
Joined
·
6,752 Posts
Is your axel off centered at all? I've got a 2.25 drop and without the adjustable pan hard bar may rear axel had kicked over to the driver side about 1 inch.
 

·
Registered
Joined
·
7,311 Posts
i've had a wheel fly off of my old stang before...for two weeks the car felt like the wind was blowing hard when i'd get it up to speed...i thought the lugs were tight too...turned out the wheel was rounding out where the studs go through and finally one day it gets that shifting feeling...i tug to the right a little..and my driver rear wheel and tire passes me as im going 55.

i'd pull the wheels off and double check everything. i now check my lugs every few weeks lol and my issue happened a year ago...it's just something that once it happens sticks in the back of your head
 

·
Registered
Joined
·
1 Posts
So happy to see some one else post about this problem. This happened to me as well on my way back to work. It was about 60 degrees out and dry. I have factory 3.73 gears and brembo pack tires. I also have a FRPP drop but im running K springs with a adjustable pan head bar and LCA... Do you think its the rear axle being off centered? I feel like my rear end under power is slipping out and not holding traction as well as it did 2k miles ago.. Please HELP!!!
 

·
Abominable Mustang
Joined
·
1,926 Posts
i was told anything 1" and less in drop a panhard bar wasnt needed
You should still have the stock nonadjustable panhard rod though. What you're talking about is getting an adjustable panhard rod when you drop the car more than about 1".
 

·
Abominable Mustang
Joined
·
1,926 Posts
Because when you lower your mustang, the rear axle will shift to the left. The adjustable panhard rod will be able to move it back to center.
 
1 - 20 of 22 Posts
Top