Mustang Evolution Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
So today I decided to tackle another project, getting light on the inside. Well I went down to the good old advanced auto and first tried to get a new bulb for the map light, which I learnt is obsolete, but I don't think it works anyways. So I got a new bulb for the dome light and it lit up, but it didn't go off. I have takin it out, but I do want to fix it

---------- Post added at 11:02 PM ---------- Previous post was at 11:00 PM ----------

What could it be? The switches in the doors? Something else?
 

·
Registered
Joined
·
861 Posts
So today I decided to tackle another project, getting light on the inside. Well I went down to the good old advanced auto and first tried to get a new bulb for the map light, which I learnt is obsolete, but I don't think it works anyways. So I got a new bulb for the dome light and it lit up, but it didn't go off. I have takin it out, but I do want to fix it

---------- Post added at 11:02 PM ---------- Previous post was at 11:00 PM ----------

What could it be? The switches in the doors? Something else?
Do you have a multimeter? Start testing!
 

·
Registered
Joined
·
681 Posts
For an 87, your wires are slowly getting old. Like the previous post said get a m- meter and do some tests. Try searching for power further down the wire in case the ends are worn. They turn brown instead of copper. Means less conductivity. A Meter with a buzzer helps to find ground easier. Work your way back to the fuze box. Any wire you skin make sure u tape it up. My 2 cents. I have a 97, so I can imagine.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #4
For an 87, your wires are slowly getting old. Like the previous post said get a m- meter and do some tests. Try searching for power further down the wire in case the ends are worn. They turn brown instead of copper. Means less conductivity. A Meter with a buzzer helps to find ground easier. Work your way back to the fuze box. Any wire you skin make sure u tape it up. My 2 cents. I have a 97, so I can imagine.
That makes since, but the light doesn't go off, would that be caused by old wiring? I would think if it was old wiring the light wouldn't come on.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #5
Update. I got the dome light working properly! All i did was soak the push button things in the door jams down with some liquid wrench penetrating oil and let it sit for a few days. Put the bulb in and shut the door and it went off!
 

·
Registered
Joined
·
2,907 Posts
Is ur insurerment gauge dimmer switched on?
 
1 - 7 of 7 Posts
Top